	<!doctype html>
<html lang="en-US" prefix="og: http://ogp.me/ns#" class="no-js">
<head>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0" />

    <link rel="preconnect" href="https://ksassets.timeincuk.net" crossorigin>
<link rel="preconnect" href="https://assets.ti-media.net" crossorigin>
<link rel="preconnect" href="https://www.google-analytics.com" crossorigin>
<link rel="preconnect" href="https://js-sec.indexww.com" crossorigin>
<link rel="preconnect" href="https://www.googletagservices.com" crossorigin>
<link rel="preconnect" href="https://display.apester.com" crossorigin>
<link rel="preconnect" href="https://player.apester.com" crossorigin>
<link rel="preconnect" href="https://renderer.apester.com" crossorigin>
<link rel="preconnect" href="https://static.apester.com" crossorigin>
<link rel="preconnect" href="https://content.jwplatform.com" crossorigin>
<link rel="preconnect" href="https://jwpltx.com" crossorigin>
<link rel="preconnect" href="https://ssl.p.jwpcdn.com" crossorigin>
<link rel="preconnect" href="https://cdn.taboola.com" crossorigin>
<link rel="preconnect" href="https://trc.taboola.com" crossorigin>


    		<!-- TI performance tracking -->
		<script>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</script>
		<!-- End TI performance tracking --><title>Riverdale Season 4 Episode 1 Recap: A fitting tribute to Luke Perry</title>
<link rel="preload" href="https://www.nme.com/wp-content/plugins/keystone-jwplayer/assets/css/main.css" as="style" onload="this.onload=null;this.rel='stylesheet'"><script async>!function(n){"use strict";n.loadCSS||(n.loadCSS=function(){});var o=loadCSS.relpreload={};if(o.support=function(){var e;try{e=n.document.createElement("link").relList.supports("preload")}catch(t){e=!1}return function(){return e}}(),o.bindMediaToggle=function(t){var e=t.media||"all";function a(){t.addEventListener?t.removeEventListener("load",a):t.attachEvent&&t.detachEvent("onload",a),t.setAttribute("onload",null),t.media=e}t.addEventListener?t.addEventListener("load",a):t.attachEvent&&t.attachEvent("onload",a),setTimeout(function(){t.rel="stylesheet",t.media="only x"}),setTimeout(a,3e3)},o.poly=function(){if(!o.support())for(var t=n.document.getElementsByTagName("link"),e=0;e<t.length;e++){var a=t[e];"preload"!==a.rel||"style"!==a.getAttribute("as")||a.getAttribute("data-loadcss")||(a.setAttribute("data-loadcss",!0),o.bindMediaToggle(a))}},!o.support()){o.poly();var t=n.setInterval(o.poly,500);n.addEventListener?n.addEventListener("load",function(){o.poly(),n.clearInterval(t)}):n.attachEvent&&n.attachEvent("onload",function(){o.poly(),n.clearInterval(t)})}"undefined"!=typeof exports?exports.loadCSS=loadCSS:n.loadCSS=loadCSS}("undefined"!=typeof global?global:this);</script><style>
@font-face {
	font-family: "keystone";
	font-weight: normal;
	font-style: normal;
	font-display: fallback;
	src:	url("//www.nme.com/wp-content/themes/simba-theme/assets/fonts/standard.woff2?v=1570536881") format("woff2"),
	url("//www.nme.com/wp-content/themes/simba-theme/assets/fonts/standard.woff?v=1570536881") format("woff");
}
.icon-spinner {
	background-image: url("//www.nme.com/wp-content/themes/simba-theme/assets/images/spinner.gif");
}

</style><style>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</style><link rel="preload" href="https://www.nme.com/wp-content/themes/simba-theme/assets/css/sites/55.min.css?1570536881" as="style" onload="this.onload=null;this.rel='stylesheet'">		<script type="text/javascript">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</script>
<meta name="description" content="In the premiere of Riverdale&#039;s fourth season, the cast and crew paid tribute to their colleague and friend Luke Perry."/>
<meta name="robots" content="noodp"/>
<link rel="canonical" href="https://www.nme.com/blogs/tv-blogs/riverdale-season-4-episode-1-luke-perry-tribute-2555955" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Riverdale Season 4 Episode 1 Recap: A fitting tribute to Luke Perry" />
<meta property="og:description" content="In the premiere of Riverdale&#039;s fourth season, the cast and crew paid tribute to their colleague and friend Luke Perry." />
<meta property="og:url" content="https://www.nme.com/blogs/tv-blogs/riverdale-season-4-episode-1-luke-perry-tribute-2555955" />
<meta property="og:site_name" content="NME" />
<meta property="article:publisher" content="https://www.facebook.com/nmemagazine" />
<meta property="article:tag" content="Netflix" />
<meta property="article:section" content="NME Blogs" />
<meta property="article:published_time" content="2019-10-10T17:39:11+01:00" />
<meta property="fb:app_id" content="208195102528120" />
<meta property="og:image" content="https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/10/RR9GH9.jpg" />
<meta property="og:image:width" content="2000" />
<meta property="og:image:height" content="1270" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="In the premiere of Riverdale&#039;s fourth season, the cast and crew paid tribute to their colleague and friend Luke Perry." />
<meta name="twitter:title" content="Riverdale Season 4 Episode 1 Recap: A fitting tribute to Luke Perry" />
<meta name="twitter:site" content="@NME" />
<meta name="twitter:image" content="https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/10/RR9GH9.jpg" />
<meta name="twitter:creator" content="@HannahMylrea" />
<!-- / Yoast SEO plugin. -->

<link rel="alternate" type="application/rss+xml" title="NME &raquo; Feed" href="https://www.nme.com/feed" />
<script type='text/javascript' src='https://www.nme.com/wp-content/themes/simba-theme/assets/js/dist/jquery-3.3.1.min.js?ver=3.3.1'></script>
<link rel='https://api.w.org/' href='https://www.nme.com/wp-json/' />
<link rel='shortlink' href='https://www.nme.com/?p=2555955' />
<link rel="alternate" type="application/json+oembed" href="https://www.nme.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nme.com%2Fblogs%2Ftv-blogs%2Friverdale-season-4-episode-1-luke-perry-tribute-2555955" />
<link rel="alternate" type="text/xml+oembed" href="https://www.nme.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nme.com%2Fblogs%2Ftv-blogs%2Friverdale-season-4-episode-1-luke-perry-tribute-2555955&#038;format=xml" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"NewsArticle","headline":"&#8216;Riverdale&#8217; Season 4 Episode 1 recap: a beautiful and poignant tribute to Luke Perry","url":"https:\/\/www.nme.com\/blogs\/tv-blogs\/riverdale-season-4-episode-1-luke-perry-tribute-2555955","thumbnailUrl":"https:\/\/ksassets.timeincuk.net\/wp\/uploads\/sites\/55\/2019\/10\/RR9GH9.jpg","image":"https:\/\/ksassets.timeincuk.net\/wp\/uploads\/sites\/55\/2019\/10\/RR9GH9.jpg","dateCreated":"2019-10-10T17:39:11+00:00","datePublished":"2019-10-10T17:39:11+00:00","dateModified":"2019-10-10T17:39:11+00:00","articleSection":"TV Blogs","creator":{"@type":"Person","name":"Hannah Mylrea"},"author":{"@type":"Person","name":"Hannah Mylrea"},"publisher":{"@type":"Organization","name":"NME","logo":{"@type":"http:\/\/schema.org\/ImageObject","url":"https:\/\/ksassets.timeincuk.net\/wp\/uploads\/sites\/55\/2018\/06\/REV.NME_.WEB_.80px-1.png"}},"mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.nme.com\/blogs\/tv-blogs\/riverdale-season-4-episode-1-luke-perry-tribute-2555955"},"keywords":["NME Blogs","TV Blogs","Netflix"]}</script>
<meta property="fb:pages" content="9577714166" />		<script type="text/javascript" charset="utf-8">
		(function(a,b,c,d){
		    var protocol = "https://";
		    a="assets.ti-media.net/js/e1512726446_2a23693/min/gtm/utils-min.js";
		    b=document;c='script';d=b.createElement(c);d.src=protocol+a;d.async=true;d.type='text/java'+c;
		    a=b.getElementsByTagName(c)[0];a.parentNode.insertBefore(d,a);
		 })();
		</script>
	      <!-- Google Tag Manager -->
      <script>(function ( w, d, s, l, i ) {
          w[ l ] = w[ l ] || [];
          w[ l ].push({
            'gtm.start' :
              new Date().getTime(), event : 'gtm.js'
          });
          var f = d.getElementsByTagName(s)[ 0 ],
            j = d.createElement(s), dl = l != 'dataLayer' ? '&l=' + l : '';
          j.async = true;
          j.src =
            'https://www.googletagmanager.com/gtm.js?id=' + i + dl;
          f.parentNode.insertBefore(j, f);
        })(window, document, 'script', 'dataLayer','GTM-PFB5MWX');</script>
      <!-- End Google Tag Manager -->
      <link rel="amphtml" href="https://www.nme.com/blogs/tv-blogs/riverdale-season-4-episode-1-luke-perry-tribute-2555955/amp"><link rel="icon" href="https://ksassets.timeincuk.net/wp/uploads/sites/55/2016/10/cropped-nme-site-icon-150x150.jpg" sizes="32x32" />
<link rel="icon" href="https://ksassets.timeincuk.net/wp/uploads/sites/55/2016/10/cropped-nme-site-icon-300x300.jpg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://ksassets.timeincuk.net/wp/uploads/sites/55/2016/10/cropped-nme-site-icon-300x300.jpg" />
<meta name="msapplication-TileImage" content="https://ksassets.timeincuk.net/wp/uploads/sites/55/2016/10/cropped-nme-site-icon-300x300.jpg" />
		<style type="text/css" id="wp-custom-css">
			@media (min-width: 45.5em) {
	.listing--hero h3 {
    max-width: 30em;		
	}
}

@media (max-width: 45.49em) {
	#post-inline-1 {
		display: none !important;
	}
}

.tax-person_category .description-primary img {
	max-width: 100%;
	height: auto;
}

.featured-image #dice-event-list-widget img {
	width: unset;
	max-width: 100%;
}

.ad-container {
	pointer-events: unset !important;
}

.listing--hero h3 {
	text-align:left;
}

@media (max-width: 45.49em) {
	.listing--hero h3 {
		text-align:center;
	}
	
	.listing--hero .entry-content {
		padding-top:10px!important;
		padding-bottom:0px!important;
	}
}		</style>
	    			</head>

<body class="post-template-default single single-post postid-2555955 single-format-standard has-adverts y2019 m10 d10 h17 riverdale-season-4-episode-1-luke-perry-tribute standard slim-header">

	<div class="header-advert-wrapper">
		<aside class="row advert header-advert sticky-anchor is-absolute">
			<div class="section-content">
				<div id="header-1" class="ipc-advert"></div>			</div>
		</aside>
	</div>

<div class="parallax-wrapper parallax-wrapper--header"></div>

      <!-- Google Tag Manager (noscript) -->
      <noscript>
        <iframe
            src="https://www.googletagmanager.com/ns.html?id=GTM-PFB5MWX"
            height="0" width="0"
            style="display:none;visibility:hidden"></iframe>
      </noscript>
      <!-- End Google Tag Manager (noscript) -->
      
<div id="wrapper" class="hfeed">

			<header id="header" role="banner" class="header s-container has-single-tier">

	<div class="header__inner">

		
						<div itemscope itemtype="http://schema.org/Organization" class="logo header-slot header-slot-">
    <a itemprop="url" href="/" title="NME" name="NME">
    	<span class="hide">Link to home</span>
	<picture>
		<source media="(min-width: 728px)" srcset="https://ksassets.timeincuk.net/wp/uploads/sites/55/2018/06/REV.NME_.WEB_.80px-1.png" >
		<source media="(max-width: 727px)" srcset="https://ksassets.timeincuk.net/wp/uploads/sites/55/2018/06/REV.NME_.WEB_.80px-1.png" >
		<img src="https://ksassets.timeincuk.net/wp/uploads/sites/55/2018/06/REV.NME_.WEB_.80px-1.png" alt="hero profile" itemprop="logo" aria-hidden="true" data-pin-nopin="true">
	</picture>
    </a>
</div>

		
	</div>

		<nav>
	<ul class="navigation hide-overflow-items" data-nav="closed">
					<li class="has-subnav">
				<a href="/news/music" class= " "    name="Music">
									Music
								</a>
									<span class="submenu-toggle icon-arrow-down"></span>
					<ul class="navigation-secondary">
													<li >
								<a href="https://www.nme.com/news/music"     name="Music News">Music News</a>
															</li>
													<li >
								<a href="https://www.nme.com/blogs/nme-blogs"     name="Opinion">Opinion</a>
															</li>
													<li >
								<a href="https://www.nme.com/music-interviews"     name="Music Interviews">Music Interviews</a>
															</li>
													<li >
								<a href="/artists"     name="Artists">Artists</a>
															</li>
													<li >
								<a href="https://www.nme.com/reviews/album"     name="Album Reviews">Album Reviews</a>
															</li>
													<li >
								<a href="https://www.nme.com/new-album-releases"     name="Album Release Dates">Album Release Dates</a>
															</li>
													<li >
								<a href="http://www.nme.com/reviews/live"     name="Live reviews">Live reviews</a>
															</li>
													<li >
								<a href="https://artists.nme.com/artists/"     target="_blank"  name="Emerging Artists">Emerging Artists</a>
															</li>
													<li >
								<a href="https://www.nme.com/blogs/nme-radar"     name="New Music">New Music</a>
															</li>
											</ul>
							</li>
					<li >
				<a href="https://www.nme.com/festivals-home" class= " "    name="Festivals">
									Festivals
								</a>
							</li>
					<li class="has-subnav">
				<a href="https://www.nme.com/news/film" class= " "    name="Film">
									Film
								</a>
									<span class="submenu-toggle icon-arrow-down"></span>
					<ul class="navigation-secondary">
													<li >
								<a href="https://www.nme.com/news/film"     name="Film News">Film News</a>
															</li>
													<li >
								<a href="https://www.nme.com/reviews/movie"     name="Film Reviews">Film Reviews</a>
															</li>
													<li >
								<a href="https://www.nme.com/blogs/the-movies-blog"     name="Film Blogs">Film Blogs</a>
															</li>
													<li >
								<a href="https://www.nme.com/film-interviews"     name="Film Interviews">Film Interviews</a>
															</li>
													<li >
								<a href="/film-releases"     name="Film Release Dates">Film Release Dates</a>
															</li>
													<li >
								<a href="http://www.nme.com/tag/horror"     name="Horror">Horror</a>
															</li>
											</ul>
							</li>
					<li class="has-subnav">
				<a href="/news/tv" class= " "    name="TV">
									TV
								</a>
									<span class="submenu-toggle icon-arrow-down"></span>
					<ul class="navigation-secondary">
													<li >
								<a href="https://www.nme.com/news/tv"     name="TV News">TV News</a>
															</li>
													<li >
								<a href="https://www.nme.com/blogs/tv-blogs"     name="TV Blogs">TV Blogs</a>
															</li>
													<li >
								<a href="https://www.nme.com/tv-interviews"     name="TV Interviews">TV Interviews</a>
															</li>
											</ul>
							</li>
					<li class="has-subnav">
				<a href="/videos" class= " "    name="Video">
									Video
								</a>
									<span class="submenu-toggle icon-arrow-down"></span>
					<ul class="navigation-secondary">
													<li >
								<a href="/videos/song-stories"     name="Song Stories">Song Stories</a>
															</li>
													<li >
								<a href="/videos/basement-sessions"     name="Basement Sessions">Basement Sessions</a>
															</li>
													<li >
								<a href="/videos/90-second-interview"     name="90 Second Interviews">90 Second Interviews</a>
															</li>
											</ul>
							</li>
					<li class="has-subnav">
				<a href="http://www.nmemerch.com" class= " "    name="Shop">
									Shop
								</a>
									<span class="submenu-toggle icon-arrow-down"></span>
					<ul class="navigation-secondary">
													<li >
								<a href="http://www.nmemerch.com"   rel="nofollow"    name="Merch">Merch</a>
															</li>
													<li >
								<a href="http://nme.backstreetmerch.com/artist/nme/magazines"   rel="nofollow"    name="NME Special Issues">NME Special Issues</a>
															</li>
													<li >
								<a href="http://nme.backstreetmerch.com/search?search=uncut+ultimate+music+guide"   rel="nofollow"    name="Ultimate Music Guides">Ultimate Music Guides</a>
															</li>
													<li >
								<a href="http://nme.backstreetmerch.com/artist/uncut-history-of-rock/magazines"   rel="nofollow"    name="History Of Rock">History Of Rock</a>
															</li>
											</ul>
							</li>
					<li class="has-subnav">
				<a href="http:/www.nme.com/tickets" class= " "    name="The Gig Guide">
									The Gig Guide
								</a>
									<span class="submenu-toggle icon-arrow-down"></span>
					<ul class="navigation-secondary">
													<li >
								<a href="https://www.nme.com/tickets/birmingham"     name="Birmingham">Birmingham</a>
															</li>
													<li >
								<a href="https://www.nme.com/tickets/brighton-gig-guide"     name="Brighton">Brighton</a>
															</li>
													<li >
								<a href="http://www.nme.com/tickets/bristol-gig-guide"     name="Bristol">Bristol</a>
															</li>
													<li >
								<a href="https://www.nme.com/tickets/cardiff-gig-guide"     name="Cardiff">Cardiff</a>
															</li>
													<li >
								<a href="https://www.nme.com/tickets/leeds-gig-guide"     name="Leeds">Leeds</a>
															</li>
													<li >
								<a href="https://www.nme.com/tickets/liverpool-gig-guide"     name="Liverpool">Liverpool</a>
															</li>
													<li >
								<a href="https://www.nme.com/tickets/london-gig-guide"     name="London">London</a>
															</li>
													<li >
								<a href="https://www.nme.com/tickets/manchester-gig-guide"     name="Manchester">Manchester</a>
															</li>
													<li >
								<a href="https://www.nme.com/tickets/newcastle-gig-guide"     name="Newcastle">Newcastle</a>
															</li>
													<li >
								<a href="https://www.nme.com/tickets/paris-gig-guide"     name="Paris">Paris</a>
															</li>
													<li >
								<a href="https://www.nme.com/tickets/sheffield-gig-guide"     name="Sheffield">Sheffield</a>
															</li>
											</ul>
							</li>
					<li >
				<a href="https://aaa.nme.com" class= " "    name="NME AAA">
									NME AAA
								</a>
							</li>
					<li >
				<a href="http://www.nme.com/audio" class= " "    name="NME Radio">
									NME Radio
								</a>
							</li>
					<li >
				<a href="/discount-codes" class= " "    name="Discount Codes">
									Discount Codes
								</a>
							</li>
		
		
					<li class="has-subnav header-slot-right nav-follow">
				<span class="submenu-toggle icon-arrow-down"></span>
				<a href="javascript:void(0);" name="Follow us on social media">Follow</a>
				<ul class="nav-social">
											<li><a href="https://www.facebook.com/nmemagazine" target="_blank" rel="noopener" name="Follow us on Facebook">Facebook</a></li>
											<li><a href="https://twitter.com/nme" target="_blank" rel="noopener" name="Follow us on Twitter">Twitter</a></li>
											<li><a href="https://plus.google.com/+NME/posts" target="_blank" rel="noopener" name="Follow us on Google+">Google+</a></li>
											<li><a href="https://www.instagram.com/nmemagazine/" target="_blank" rel="noopener" name="Follow us on Instagram">Instagram</a></li>
									</ul>
			</li>
		
		<li class="menu-more has-subnav">
			<a href="javascript:void(0)" name="See more menu items">More <span class="icon-plus"></span></a>
			<ul></ul>
		</li>
	</ul>

	<a href="javascript:void(0)" class="search-site icon-search" name="Search the site"><span class="hide">Search</span></a>

	<a href="#" class="menu-icon-link hidden-md hidden-lg" name="Toggle the site menu">
		<span class="menu-toggle icon-menu"><span class="hide">Menu</span></span>
	</a>

	<form role="search" method="get" class="search-form form-inline s-container" action="/">
		<div class="input-group">
			<input type="search" value="" name="s" class="input-sm search-field form-control" placeholder="Search">
							<button type="submit" class="btn btn--sm" name="search">Search</button>
						<div class="message-wrapper">
				<label for="s" class="message message--type">Type to search</label>
				<label for="s" class="message message--search hide">Press enter or click on the search icon</label>
			</div>
		</div>
	</form>
</nav>

</header>	
	<div id="content" role="main" class="container-fluid" >
													<div class="trending">
	<div class="s-container trending__inner">
		<div class="s-container__inner">
			<div class="trending__title">Trending:</div>
				<div class="trending-list__outer">
					<ul class="trending-list__inner">
													<li><a href="/audio/nme1/player/"  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2339561"     name="Listen Now">Listen Now</a></li>
													<li><a href="/artists/tekashi-6ix9ine"  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2339563"     name="Tekashi 6ix9ine">Tekashi 6ix9ine</a></li>
													<li><a href="/blogs/the-movies-blog/harley-quinn-movie-trailer-release-date-news-cast-2321968"  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2339564"     name="Birds of Prey">Birds of Prey</a></li>
													<li><a href="/tag/podcasts"  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2339565"     name="Best podcasts">Best podcasts</a></li>
													<li><a href="https://www.nme.com/blogs/nme-blogs/vinyl-releases-this-week-josh-homme-diiv-angel-olsen-2536648"  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2339566"     name="Vinyl guide">Vinyl guide</a></li>
													<li><a href="/artists/the-1975"  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2339567"     name="The 1975">The 1975</a></li>
													<li><a href="/blogs/best-albums-of-2019-2449289"  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2405103"     name="Best albums of 2019">Best albums of 2019</a></li>
													<li><a href="/list/100-best-songs-of-the-1980s-1161"  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2339571"     name="80s songs">80s songs</a></li>
											</ul>
			</div>
			<div class="trending__fade trending__fade--before"></div>
			<div class="trending__fade trending__fade--after"></div>
		</div>
	</div>
</div>					
			
				<article
			class="post-2555955 post type-post status-publish format-standard has-post-thumbnail hentry category-nme-blogs category-tv-blogs tag-netflix publication_name-nme"
			role="article"
			itemprop=""
			itemscope itemtype="http://schema.org/Article"
	>
					<meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.nme.com/blogs/tv-blogs/riverdale-season-4-episode-1-luke-perry-tribute-2555955" content="" />
			<div itemprop="publisher" itemscope itemtype="http://schema.org/Organization">
	<meta itemprop="name" content="NME" />
	<div itemprop="logo" itemscope itemtype="http://schema.org/ImageObject">
		<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/55/2018/06/REV.NME_.WEB_.80px-1.png" />
	</div>
</div>					
							
					<nav class="breadcrumb s-container"  role="navigation">
	<div class="s-container__inner">
		<ul xmlns:v="http://rdf.data-vocabulary.org/#">
							<li typeof="v:Breadcrumb">
					<a href="https://www.nme.com" rel="v:url" property="v:title" name="Home">Home</a>
				</li>
							<li typeof="v:Breadcrumb">
					<a href="https://www.nme.com/blogs" rel="v:url" property="v:title" name="Blogs">Blogs</a>
				</li>
							<li typeof="v:Breadcrumb">
					<a href="https://www.nme.com/blogs/tv-blogs" rel="v:url" property="v:title" name="TV Blogs">TV Blogs</a>
				</li>
					</ul>
	</div>
</nav>		
					
		
		<div class="post-main">

							<header class="post-header post-header--article">
					<h1 class="title-primary" itemprop="headline">
													&#8216;Riverdale&#8217; Season 4 Episode 1 recap: a beautiful and poignant tribute to Luke Perry
											</h1>

																
											<div class="post-author">
			<img
			alt="Hannah Mylrea"
			src="https://ksassets.timeincuk.net/wp/uploads/sites/55/2018/03/29026392_10160079712285156_4064729545307959342_n-150x150.jpeg"
			class="post-author--img"
			height="145"
			width="145">
		<small class="post-author-info">
					<span>
							</span>
			<span itemprop="author" itemscope itemtype="http://schema.org/Person">
				<a class="post-author__name url fn n" href="https://www.nme.com/author/hannahmylrea-hemmings" name="A post from Hannah Mylrea" itemprop="url">
					<span class="author vcard" itemprop="name">Hannah Mylrea</span>
			    </a>
			</span>
		
		
					<span>
								<time datetime="2019-10-10T17:39:11+01:00">Oct 10, 2019 5:39 pm BST</time>
			</span>
						<meta itemprop="datePublished" content="2019-10-10T17:39:11+01:00"/>		<meta itemprop="dateModified" content="2019-10-10T17:39:11+01:00"/>	</small>
</div>					
											<div class="social-share">
										<ul class="pw-widget hidden-xs">
							<li>
					<a
							href="https://www.facebook.com/sharer/sharer.php?u=https://www.nme.com/blogs/tv-blogs/riverdale-season-4-episode-1-luke-perry-tribute-2555955"
							target="_blank"
							 rel="noopener" 							class="share-button pw-button-facebook icon-social-facebook "
							data-url="https://www.nme.com/blogs/tv-blogs/riverdale-season-4-episode-1-luke-perry-tribute-2555955"
							name="Share this page on facebook"
					></a>
				</li>
							<li>
					<a
							href="https://twitter.com/intent/tweet?url=https://www.nme.com/blogs/tv-blogs/riverdale-season-4-episode-1-luke-perry-tribute-2555955&text=&#8216;Riverdale&#8217; Season 4 Episode 1 recap: a beautiful and poignant tribute to Luke Perry"
							target="_blank"
							 rel="noopener" 							class="share-button pw-button-twitter icon-social-twitter "
							data-url="https://www.nme.com/blogs/tv-blogs/riverdale-season-4-episode-1-luke-perry-tribute-2555955"
							name="Share this page on twitter"
					></a>
				</li>
							<li>
					<a
							href="http://pinterest.com/pin/create/button/?url=https://www.nme.com/blogs/tv-blogs/riverdale-season-4-episode-1-luke-perry-tribute-2555955&description=&#8216;Riverdale&#8217; Season 4 Episode 1 recap: a beautiful and poignant tribute to Luke Perry"
							target="_blank"
							 rel="noopener" 							class="share-button pw-button-pinterest icon-social-pinterest "
							data-url="https://www.nme.com/blogs/tv-blogs/riverdale-season-4-episode-1-luke-perry-tribute-2555955"
							name="Share this page on pinterest"
					></a>
				</li>
								</ul>
										<ul class="pw-widget hidden-sm hidden-md hidden-lg">
							<li>
					<a
							href="https://www.facebook.com/sharer/sharer.php?u=https://www.nme.com/blogs/tv-blogs/riverdale-season-4-episode-1-luke-perry-tribute-2555955"
							target="_blank"
							 rel="noopener" 							class="share-button pw-button-facebook icon-social-facebook "
							data-url="https://www.nme.com/blogs/tv-blogs/riverdale-season-4-episode-1-luke-perry-tribute-2555955"
							name="Share this page on facebook"
					></a>
				</li>
							<li>
					<a
							href="https://twitter.com/intent/tweet?url=https://www.nme.com/blogs/tv-blogs/riverdale-season-4-episode-1-luke-perry-tribute-2555955&text=&#8216;Riverdale&#8217; Season 4 Episode 1 recap: a beautiful and poignant tribute to Luke Perry"
							target="_blank"
							 rel="noopener" 							class="share-button pw-button-twitter icon-social-twitter "
							data-url="https://www.nme.com/blogs/tv-blogs/riverdale-season-4-episode-1-luke-perry-tribute-2555955"
							name="Share this page on twitter"
					></a>
				</li>
							<li>
					<a
							href="http://pinterest.com/pin/create/button/?url=https://www.nme.com/blogs/tv-blogs/riverdale-season-4-episode-1-luke-perry-tribute-2555955&description=&#8216;Riverdale&#8217; Season 4 Episode 1 recap: a beautiful and poignant tribute to Luke Perry"
							target="_blank"
							 rel="noopener" 							class="share-button pw-button-pinterest icon-social-pinterest "
							data-url="https://www.nme.com/blogs/tv-blogs/riverdale-season-4-episode-1-luke-perry-tribute-2555955"
							name="Share this page on pinterest"
					></a>
				</li>
								</ul>
	</div>
					
					
											<div class="post__award">
	
	
	</div>									</header>
						
							<div id="single-sidebar" class="single-sidebar single-sidebar--article">

	
	
		
		
		
		
	
	<div class="ad-container ad-sticky">
		
		<div id="post-side-1" class="ipc-advert"></div>		
	</div>

	


	
		<div class="ad-container ad-sticky">
		
			<div id="post-side-2" class="ipc-advert"></div>			
		</div>

		<section id="keystone-query-widget-id-15" class="palette-hero  hide-widget-title keystone-query-widget premium_sidebar_2"><div class="s-container__inner">
	<ul
		class="listing-items"
				data-post-count="1"
	>
					
			<li class="listing-item">
	 <a class="entry listing-entry" href="https://www.nme.com/tove-lo-interview-sunshine-kitty-big-read" title="The Big Read – Tove Lo: &#8220;Sexuality is a fluid thing – it&#8217;s hard to be just one way&#8221;" name="The Big Read – Tove Lo: &#8220;Sexuality is a fluid thing – it&#8217;s hard to be just one way&#8221;"> 																<div class="entry-media">
				<div class="entry-media-inner entry-image image-crop">
					<img src="https://ksassets.timeincuk.net/wp/uploads/sites/55/2017/10/placeholder.jpg"
     data-src="https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/10/Tove-Web-Header-620x394.jpg"
     data-id="2553879"
     data-sizes="auto"
     class="image-sm lazyload blur-up"
     alt=""
     width="620"
	 height="394"
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/10/Tove-Web-Header-320x203.jpg 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/10/Tove-Web-Header-620x394.jpg 620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/10/Tove-Web-Header-920x584.jpg 920w,
				https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/10/Tove-Web-Header-1220x775.jpg 1220w,
				https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/10/Tove-Web-Header-1620x1029.jpg 1620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/10/Tove-Web-Header-1920x1219.jpg 1920w,
	"/>
<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/10/Tove-Web-Header-620x394.jpg">
<meta itemprop="width" content="620">
<meta itemprop="height" content="394">				</div>
			</div>
		
									
					<div class="entry-content">
									
													<h3><span>The Big Read – Tove Lo: &#8220;Sexuality is a fluid thing – it&#8217;s hard to be just one way&#8221;</span></h3>
																										
					
																</div>
			 </a> </li>
			
			
			</ul>
</div></section><section id="keystone-query-widget-id-19" class="palette-a listing--single listing--single-b s-container image-aspect-landscape visible-md hidden-xs hidden-sm default keystone-query-widget premium_sidebar_2"><h2 class="widgettitle heading"><span>Latest News</span></h2><div class="s-container__inner">
	<ul
		class="listing-items"
				data-post-count="3"
	>
					
			<li class="listing-item">
	 <a class="entry listing-entry" href="https://www.nme.com/blogs/tv-blogs/riverdale-season-4-episode-1-luke-perry-tribute-2555955" title="&#8216;Riverdale&#8217; Season 4 Episode 1 recap: a beautiful and poignant tribute to Luke Perry" name="&#8216;Riverdale&#8217; Season 4 Episode 1 recap: a beautiful and poignant tribute to Luke Perry"> 																<div class="entry-media">
				<div class="entry-media-inner entry-image image-crop">
					<img src="https://ksassets.timeincuk.net/wp/uploads/sites/55/2017/10/placeholder.jpg"
     data-src="https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/10/RR9GH9-620x394.jpg"
     data-id="2555962"
     data-sizes="auto"
     class="image-sm lazyload blur-up"
     alt="Luke Perry stars in a 2017 episode of Riverdale"
     width="620"
	 height="394"
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/10/RR9GH9-320x203.jpg 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/10/RR9GH9-620x394.jpg 620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/10/RR9GH9-920x584.jpg 920w,
				https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/10/RR9GH9-1220x775.jpg 1220w,
				https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/10/RR9GH9-1620x1029.jpg 1620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/10/RR9GH9-1920x1219.jpg 1920w,
	"/>
<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/10/RR9GH9-620x394.jpg">
<meta itemprop="width" content="620">
<meta itemprop="height" content="394">				</div>
			</div>
		
									
					<div class="entry-content">
									
													<h3><span>&#8216;Riverdale&#8217; Season 4 Episode 1 recap: a beautiful and poignant tribute to Luke Perry</span></h3>
																										
					
																</div>
			 </a> </li>
			
			
					
			<li class="listing-item">
	 <a class="entry listing-entry" href="https://www.nme.com/news/tv/game-of-thrones-season-8-finale-key-scene-cut-2556003" title="&#8216;Game of Thrones&#8217; cut a key scene in the Season 8 finale" name="&#8216;Game of Thrones&#8217; cut a key scene in the Season 8 finale"> 																<div class="entry-media">
				<div class="entry-media-inner entry-image image-crop">
					<img src="https://ksassets.timeincuk.net/wp/uploads/sites/55/2017/10/placeholder.jpg"
     data-src="https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/08/gameofthrones-1024x650-620x394.jpg"
     data-id="2543042"
     data-sizes="auto"
     class="image-sm lazyload blur-up"
     alt=""
     width="620"
	 height="394"
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/08/gameofthrones-1024x650-320x203.jpg 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/08/gameofthrones-1024x650-620x394.jpg 620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/08/gameofthrones-1024x650-920x584.jpg 920w,
				https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/08/gameofthrones-1024x650-1220x775.jpg 1220w,
				https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/08/gameofthrones-1024x650-1620x1029.jpg 1620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/08/gameofthrones-1024x650-1920x1219.jpg 1920w,
	"/>
<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/08/gameofthrones-1024x650-620x394.jpg">
<meta itemprop="width" content="620">
<meta itemprop="height" content="394">				</div>
			</div>
		
									
					<div class="entry-content">
									
													<h3><span>&#8216;Game of Thrones&#8217; cut a key scene in the Season 8 finale</span></h3>
																										
					
																</div>
			 </a> </li>
							<li id="native-content-desktop" class="listing-item sharethrough-ad sharethrough-ad-hidden ipc-advert"></li>			
			
					
			<li class="listing-item">
	 <a class="entry listing-entry" href="https://www.nme.com/news/music/the-cure-robert-smith-artwork-auctioned-for-charity-the-anonymous-heart-project-2556001" title="Artwork by The Cure&#8217;s Robert Smith is being auctioned for charity" name="Artwork by The Cure&#8217;s Robert Smith is being auctioned for charity"> 																<div class="entry-media">
				<div class="entry-media-inner entry-image image-crop">
					<img src="https://ksassets.timeincuk.net/wp/uploads/sites/55/2017/10/placeholder.jpg"
     data-src="https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/10/GettyImages-1179324598-620x394.jpg"
     data-id="2556005"
     data-sizes="auto"
     class="image-sm lazyload blur-up"
     alt="Robert Smith"
     width="620"
	 height="394"
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/10/GettyImages-1179324598-320x203.jpg 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/10/GettyImages-1179324598-620x394.jpg 620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/10/GettyImages-1179324598-920x584.jpg 920w,
				https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/10/GettyImages-1179324598-1220x775.jpg 1220w,
				https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/10/GettyImages-1179324598-1620x1029.jpg 1620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/10/GettyImages-1179324598-1920x1219.jpg 1920w,
	"/>
<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/10/GettyImages-1179324598-620x394.jpg">
<meta itemprop="width" content="620">
<meta itemprop="height" content="394">				</div>
			</div>
		
									
					<div class="entry-content">
									
													<h3><span>Artwork by The Cure&#8217;s Robert Smith is being auctioned for charity</span></h3>
																										
					
																</div>
			 </a> </li>
			
			
			</ul>
</div></section>
	
	
		<div class="ad-container ad-sticky">
			
			<div id="post-side-3" class="ipc-advert"></div>			
		</div>
	

	
	</div>			
			
			<div class="post-main__inner">

				
				                    							<div class="featured-media ggnoads">
		<div id="attachment_2555962"
     class="featured-image wp-caption"
     itemprop="image" itemscope itemtype="https://schema.org/ImageObject"
>
	<figure class="image ">
		<img src="https://ksassets.timeincuk.net/wp/uploads/sites/55/2017/10/placeholder.jpg"
     data-src="https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/10/RR9GH9-920x584.jpg"
     data-id="2555962"
     data-sizes="auto"
     class=" lazyload blur-up"
     alt="Luke Perry stars in a 2017 episode of Riverdale"
     width="920"
	 height="584"
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/10/RR9GH9-320x203.jpg 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/10/RR9GH9-620x394.jpg 620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/10/RR9GH9-920x584.jpg 920w,
				https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/10/RR9GH9-1220x775.jpg 1220w,
				https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/10/RR9GH9-1620x1029.jpg 1620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/10/RR9GH9-1920x1219.jpg 1920w,
	"/>
<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/55/2019/10/RR9GH9-920x584.jpg">
<meta itemprop="width" content="920">
<meta itemprop="height" content="584">	</figure>
			<figcaption class="wp-caption-text">
			Final farewell: Riverdale's latest episode pays heartfelt tribute to its late star.
			Credit: Alamy		</figcaption>
	</div>
	</div>
									
				
				<div class="post-body">

					<div class="articleBody" itemprop="articleBody">
														<div class="post-tags icon-tags">
		<ul>
							<li><a href="https://www.nme.com/tag/netflix" class="post-tags-item" rel="tag" name="Netflix">Netflix</a></li>
					</ul>
	</div>
						
																					<p class="post-lead">The latest season premiered last night (9 October)</p>
													
																																		
													<p>In March of this year the cast and crew of <a href="https://www.nme.com/blogs/tv-blogs/riverdale-season-4-release-date-fan-theories-cast-trailers-plot-2447555"><em>Riverdale</em></a> suffered an immeasurable loss. Cast member <a href="https://www.nme.com/news/tv/luke-perry-has-died-aged-52-beverly-hills-90210-riverdale-star-tributes-2456940" target="_blank" rel="noopener">Luke Perry died at his home in Los Angeles after suffering a stroke</a>. The beloved actor was mourned by his co-stars, who rallied around each other and paid tribute to him. But with the new season of <em>Riverdale</em> having just begun, it’s now time for the fictional town’s residents to mourn his character Fred Andrews.</p>
<p>When they first started work on the episode, the production team wanted to create something that honoured Luke properly. “Very early on, we landed on the idea that Fred should have a heroic death and that that would be impactful for Archie,” showrunner Roberto Aguirre-Sacasa told <a href="https://www.thewrap.com/riverdale-season-4-premiere-luke-perry-fred-death-episode-shannen-doherty-cameo-archie/">TheWrap</a>, adding: “It felt like that’s a way that Fred could have gone. You know, after that we really, again, said that this episode really isn’t going to launch any huge stories for the season, it was really gonna be focused on that and the emotional effects of that passing for everyone…&#8221;</p>
<p><div class="ad-container ad-container--mobile"><div id="post-inline-1" class="ipc-advert"></div></div></p>
<ul>
<li><a href="https://www.nme.com/blogs/tv-blogs/riverdale-season-4-release-date-fan-theories-cast-trailers-plot-2447555"><strong>Read more:</strong> <em>Riverdale</em> season 4: release date, fan theories, cast, trailers and everything we know so far</a></li>
</ul>
<p>They’ve achieved this admirably, with an emotional and poignant opening to the teen drama&#8217;s fourth season. Last time out, Perry’s absence was explained with his character, Fred Andrews, away on a business trip. Aguirre-Sacasa clarified this decision, saying that when the show addressed Perry’s death they &#8220;didn’t want to rush that or get it wrong&#8221;. This way they got an entire episode to grieve. Moving away from the melodrama that usually permeates the narrative, &#8216;Chapter Fifty-Eight: In Memoriam&#8217;, was an understated affair (perhaps <em>Riverdale</em>’s most understated ever), focussing on the town’s reaction to Fred Andrews passing.</p>
<p><figure class="o-container youtube"><iframe width="1024" height="576" src="https://www.youtube.com/embed/tXABoOOIZs0?feature=oembed&#038;enablejsapi=1" id="keystone-player" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></figure>
</p>
<div class="ad-container ad-container--mobile"><div id="post-inline-5" class="ipc-advert"></div></div>
<p><div class="ad-container ad-container--mobile"><div id="post-inline-2" class="ipc-advert"></div></div><div id="apester-4" class="apester-desktop hidden"></div><script>window._apesterSlots=window._apesterSlots||[];window._apesterSlots.push({"id":"apester-4","class":"apester-desktop","placement":"desktop","token":"5644b81019aec6d348309b65","context":true,"tags":"","fallback":true});</script><section id="embed_code-2" class="hidden-md hidden-lg s-container sticky-anchor hide-widget-title widget_embed_code premium_inline_2"><section class="s-container listing--single listing--single-sharethrough image-aspect-landscape default sharethrough-ad sharethrough-ad-hidden">
  <div class="s-container__inner">
    <ul>
      <li id="native-content-mobile" class="listing-item">
      </li>
    </ul>
  </div>
</section></section></p>
<p>The episode opens on the teenage characters preparing for their senior year of high school. Whilst enjoying a milkshake at local haunt Pop’s Diner, Archie Andrews (KJ Apa) receives a call from the police telling him his father, Luke Perry’s Fred Andrews, was killed in a car accident.</p>
<p>It’s later revealed that Fred Andrews was actually killed in a hit and run, after he’d pulled over to help a stranded driver whose car had broken down. The rest of the episode follows Archie and co. as they bring back Fred’s body from the neighbouring county.</p>
<p>KJ Apa beautifully conveys Archie’s grief, cycling through anger (as he finds and confronts the driver of the car), denial (asking friends to identify the body for him) and acceptance (when he finally forgives the car’s drivers). The rest of the gang rally around him, sharing memories of Fred Andrews and supporting each other as they come to terms with what&#8217;s happened. Every performance, when put into context, is exceptionally brave. Especially when you consider the fact that these young actors are dealing with real life grief – and not just the loss of a beloved character.</p>
<div class="ad-container ad-container--mobile"><div id="post-inline-3" class="ipc-advert"></div></div>
<ul>
<li><a href="https://www.nme.com/tv-interviews/riverdale-cast-interview-cole-sprouse-lili-reinhart-2233885"><strong>Read more:</strong> <em>Riverdale</em>: the cast’s young stars on why the show is such a success</a></li>
</ul>
<p>Aguirre-Sacasa made good on his promise to give Fred a hero’s death, and dealt with the tragedy sensitively. Particularly moving moments, such as when Sheriff F. P. Jones (Skeet Ulrich) accompanied Archie and the body with a police escort back to town, were a nice touch. Hundreds lined the streets with banners and messages of love to Fred. Guest appearances included Luke’s <em>Beverly Hills </em>and<em> 90210</em> co-star Shannen Doherty (who played the motorist Fred had pulled over to help). A lovely personal extra. Scattered throughout the episode were snippets of old footage featuring Perry as Fred (through flashbacks), as well as photos provided by Perry&#8217;s family.</p>
<div class="ad-container ad-container--mobile"><div id="post-inline-4" class="ipc-advert"></div></div>
<div class="injection"><section id="keystone-voep-widget-2" class="visible-md hidden-xs hidden-sm s-container sticky-anchor hide-widget-title keystone-voep-widget premium_inline_before_last_p post-promo">
<div class="jwplayer-container jwplayer-margin-bottom">
<div class="jwplayer-wrapper">
<div class="jwplayer-minimize-close">
				<svg xmlns="http://www.w3.org/2000/svg" class="jw-svg-icon jw-svg-icon-close" viewBox="0 0 240 240" focusable="false">
					<path d="M134.8,120l48.6-48.6c2-1.9,2.1-5.2,0.2-7.2c0,0-0.1-0.1-0.2-0.2l-7.4-7.4c-1.9-2-5.2-2.1-7.2-0.2c0,0-0.1,0.1-0.2,0.2L120,105.2L71.4,56.6c-1.9-2-5.2-2.1-7.2-0.2c0,0-0.1,0.1-0.2,0.2L56.6,64c-2,1.9-2.1,5.2-0.2,7.2c0,0,0.1,0.1,0.2,0.2l48.6,48.7l-48.6,48.6c-2,1.9-2.1,5.2-0.2,7.2c0,0,0.1,0.1,0.2,0.2l7.4,7.4c1.9,2,5.2,2.1,7.2,0.2c0,0,0.1-0.1,0.2-0.2l48.7-48.6l48.6,48.6c1.9,2,5.2,2.1,7.2,0.2c0,0,0.1-0.1,0.2-0.2l7.4-7.4c2-1.9,2.1-5.2,0.2-7.2c0,0-0.1-0.1-0.2-0.2L134.8,120z"></path>
				</svg>
			</div>
<div
				data-player="XLmSvcDX"
				data-key="a2gj4VlA"
				data-loaded="false"
				class="jwplayer"
				id="jwplayer_a2gj4VlA_XLmSvcDX_90_div">
			</div>
</p></div>
</p></div>
</section><div id="apester-5" class="apester-mobile hidden"></div><script>window._apesterSlots=window._apesterSlots||[];window._apesterSlots.push({"id":"apester-5","class":"apester-mobile","placement":"mobile","token":"5644b81019aec6d348309b65","context":true,"tags":"","fallback":true});</script></div>
<p>The episode finishes with Archie and his classmates letting off fireworks in remembrance of the character. Speaking at Fred’s funeral, Archie tells the mourners: &#8220;His spirit and his memory lives on in this town and in everyone he&#8217;s met. Fred Andrews will always be a part of Riverdale.&#8221; And so too, through this beautiful in memoriam episode, will Luke Perry.</p>
<p><em>Riverdale airs every Thursday on Netflix</em></p>


															
																		</div>

					
																
											<div id="taboola-below-article-thumbnails"></div>									</div>
			</div>
		</div>
	</article>
			
	</div>

			<div class="parallax-wrapper parallax-wrapper--footer sticky-anchor"></div>

<footer id="footer" role="contentinfo" class="footer sticky-anchor">
	<div class="footer__row">
		<nav class="footer__col footer__col--content">
			<ul id="menu-10784" class="footer-menu footer-menu--plain">
			<li id="menu-item-419762" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-419762">
			<a href="https://www.nme.com/"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon" name="Visit our no-icon page">
				<span class="menu-icon-item icon-no-icon">
					Home
				</span>
			</a>
		</li>
			<li id="menu-item-592212" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-592212">
			<a href="https://www.nme.com/contact"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon" name="Visit our no-icon page">
				<span class="menu-icon-item icon-no-icon">
					Contact
				</span>
			</a>
		</li>
			<li id="menu-item-2512205" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2512205">
			<a href="https://www.nme.com/advertise"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon" name="Visit our no-icon page">
				<span class="menu-icon-item icon-no-icon">
					Advertise
				</span>
			</a>
		</li>
			<li id="menu-item-419764" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-419764">
			<a href="https://www.ti-mediacontent.com"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon" name="Visit our no-icon page">
				<span class="menu-icon-item icon-no-icon">
					License NME
				</span>
			</a>
		</li>
			<li id="menu-item-419765" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-419765">
			<a href="http://www.timeincuk.com/terms-and-conditions/"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon" name="Visit our no-icon page">
				<span class="menu-icon-item icon-no-icon">
					Site User Terms
				</span>
			</a>
		</li>
			<li id="menu-item-419766" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-419766">
			<a href="http://www.timeincuk.com/privacy/"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon" name="Visit our no-icon page">
				<span class="menu-icon-item icon-no-icon">
					Privacy Policy
				</span>
			</a>
		</li>
			<li id="menu-item-419767" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-419767">
			<a href="http://www.timeincuk.com/privacy/#cookies"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon" name="Visit our no-icon page">
				<span class="menu-icon-item icon-no-icon">
					Cookie Information
				</span>
			</a>
		</li>
			<li id="menu-item-2347533" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2347533">
			<a href="/discount-codes"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon" name="Visit our no-icon page">
				<span class="menu-icon-item icon-no-icon">
					Discount Codes
				</span>
			</a>
		</li>
			<li id="menu-item-2366147" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2366147">
			<a href="#"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon" name="Visit our no-icon page">
				<span class="menu-icon-item icon-no-icon">
					Privacy Settings
				</span>
			</a>
		</li>
	</ul>		</nav>
		<nav class="footer__col footer__col--sidebar">
			<div class="ad-logos">
	<a href="https://www.iabuk.com/goldstandard" class="footer__iab" target="_blank" rel="noopener" name="IAB Gold Standard">
		<img 
			src="https://ksassets.timeincuk.net/wp/uploads/sites/55/2017/10/placeholder.jpg" 
			data-src="/wp-content/themes/simba-theme/assets/images/iab_logo.png" 
			class="lazyload blur-up" 
			alt="IAB Gold Standard" 
			width="100%" />
	</a>
	<a href="https://jicwebs.org/standards/brand-safety/" class="footer__jic" target="_blank" rel="noopener" name="JIC WEBS Brand Safety">
		<img 
			src="https://ksassets.timeincuk.net/wp/uploads/sites/55/2017/10/placeholder.jpg" 
			data-src="/wp-content/themes/simba-theme/assets/images/jic_webs_logo.jpg" 
			class="lazyload blur-up" 
			alt="JIC WEBS Brand Safety" 
			width="100%" />
	</a>
</div>
			
		</nav>

		<div class="footer-legal">
			<a itemprop="url" href="" title="" name="">
			<img 
				itemprop="logo" 
				src="https://ksassets.timeincuk.net/wp/uploads/sites/55/2017/10/placeholder.jpg" 
				data-src="https://ksassets.timeincuk.net/wp/uploads/sites/55/2018/06/REV.NME_.WEB_.40px.png" 
				class="lazyload blur-up footer-logo" 
				alt="" 
				data-pin-nopin="true">
		</a>
		<sub>&copy; Copyright TI Media Limited. 161 Marsh Wall, London, E14 9SJ. All rights reserved.</sub>
	<a href="https://www.ipso.co.uk/what-we-do/" class="footer__ipso" target="_blank" rel="noopener" name="Visit the IPSO website">
		<img 
			src="https://ksassets.timeincuk.net/wp/uploads/sites/55/2017/10/placeholder.jpg" 
			data-src="https://www.nme.com/wp-content/themes/simba-theme/assets/images/ipso-light.png" 
			class="lazyload blur-up" 
			alt="IPSO Regulated" 
			width="100%" />
	</a>
</div>
		<ul id="menu-10785" class="footer-menu footer-menu--icons">
			<li id="menu-item-405763" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-405763">
			<a href="https://www.facebook.com/nmemagazine"   target="_blank" rel="noopener" class="menu-icon-item icon-social-facebook" name="Visit our facebook page">
				<span class="menu-icon-item icon-facebook">
					Facebook
				</span>
			</a>
		</li>
			<li id="menu-item-405764" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-405764">
			<a href="https://twitter.com/nme"   target="_blank" rel="noopener" class="menu-icon-item icon-social-twitter" name="Visit our twitter page">
				<span class="menu-icon-item icon-twitter">
					Twitter
				</span>
			</a>
		</li>
			<li id="menu-item-405765" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-405765">
			<a href="https://plus.google.com/+NME"   target="_blank" rel="noopener" class="menu-icon-item icon-social-google" name="Visit our google page">
				<span class="menu-icon-item icon-google">
					Google+
				</span>
			</a>
		</li>
			<li id="menu-item-405766" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-405766">
			<a href="https://www.instagram.com/nmemagazine/"   target="_blank" rel="noopener" class="menu-icon-item icon-social-instagram" name="Visit our instagram page">
				<span class="menu-icon-item icon-instagram">
					Instagram
				</span>
			</a>
		</li>
			<li id="menu-item-2036276" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2036276">
			<a href="https://uk.pinterest.com/nmemagazine/"   target="_blank" rel="noopener" class="menu-icon-item icon-social-pinterest" name="Visit our pinterest page">
				<span class="menu-icon-item icon-pinterest">
					Pinterest
				</span>
			</a>
		</li>
	</ul>	</div>
</footer>
				<script type="text/javascript">
			(function() {
				/* Include required screen size functions right here */
				var getDisplayWidth=function(){var e=0;if(typeof window.innerWidth!="undefined"){e=window.innerWidth}else if(typeof document.documentElement!="undefined"&&typeof document.documentElement.clientWidth!="undefined"&&document.documentElement.clientWidth!=0){e=document.documentElement.clientWidth}else{e=document.getElementsByTagName("body")[0].clientWidth}return Number(e)};
				var getWindowSize = getDisplayWidth();
				window.ipcTags = window.ipcTags || {};
				/* Pageskin targeting stuff */
				if(getWindowSize >= 1350) {
					window.ipcTags['pageskin'] = 'yes';
				} else {
					window.ipcTags['pageskin'] = 'no';
				}

				
				if(getWindowSize >= 690) {
					window.ipcTags.platform = 'desktop';
				} else {
					window.ipcTags.platform = 'mobile';
				}

				
				window.ipcTags['dfp_config']['required_tags'].push('pageskin');
			})();
		</script>
		<script type='text/javascript'>
			(function(d,w){
				var s = d.createElement('script');
				w.lazySizesConfig = {'expFactor':'1'};
				s.src = 'https://www.nme.com/wp-content/plugins/keystone-images/assets/js/sizes.js?ver=0.0.1';
				d.body.appendChild(s);
			})(document,window);
		</script><script type='text/javascript' src='https://www.nme.com/wp-content/plugins/keystone-apester/assets/js/apester.js?ver=1.1.14'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var keystoneJWPlayerConfig = {"viewplay":"desktop","viewplay_sticky_tabswitch":"0","sticky":"1","sticky_position":"right","mute":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.nme.com/wp-content/plugins/keystone-jwplayer/assets/js/main.js?ver=1.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var keystoneTaboolaConfig = {"lazyload":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.nme.com/wp-content/plugins/keystone-taboola/assets/js/taboola.js?ver=0.0.1'></script>
<script type='text/javascript' src='https://www.nme.com/wp-content/plugins/ipc-wordpress-digital-editions/public/assets/js/public.js?ver=2.2.2'></script>
<script type='text/javascript' src='https://www.nme.com/wp-content/themes/simba-theme/assets/js/dist/post.min.js?ver=1570536881'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var keystone_newsletter = {"form_url":"https:\/\/ti-media.slgnt.eu\/renderers\/xml.ashx?ID=nLUnUG6KOH7JVtNut_mqr75CzNVCbo18YbNezlFBjHW9kR%2B98Rc6r4aNyu50jiA2PGhvykw1_OhnBfMVr5&NEWSLETTER_CODE=XME-D&BRAND_CODE=XME&SOURCE_CODE=RRL"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.nme.com/wp-content/plugins/keystone-newsletter/widget/js/widget.js?ver=1570536881'></script>
<script type='text/javascript' src='https://www.nme.com/wp-includes/js/wp-embed.min.js?ver=NC45Ljc'></script>
		<script>
			(function(){
				var n='scr'+'ipt',p=document.getElementsByTagName(n)[0],s=document.createElement(n);
				s.async=true;
				s.src='https://ksassets.timeincuk.net/tenant/1.0.64/tenant.min.js'
				p.parentNode.insertBefore(s,p);
			})();
			var googletag = googletag || {};
			googletag.cmd = googletag.cmd || [];
			window.tenantGetterQueue = window.tenantGetterQueue || [];
			window.tenantSetterQueue = window.tenantSetterQueue || [];
		</script>
		<div id="dfpad-overlay" class="ipc-advert"></div><div id="gumgum" class="ipc-advert"></div><div id="sovrn" class="ipc-advert"></div><div id="instream" class="ipc-advert"></div>
	
</div><!-- /wrapper -->


	
	<script>
    	let _ks_modules = [
    		'billboard',
            'navigation',
            'objectFit',
            'sharethroughListener',
            'select2',
        ];
	</script>


	<script>

		_ks_modules.push('featuredVideo');

	</script>



	<script>
        for (let i = 0; i < _ks_modules.length; i++) {
            let module = window[_ks_modules[i]];
            if (typeof module !== 'undefined' && typeof module.init === 'function') {
                module.init();
            }
        }
	</script>


	<script src="https://blog.bandlabtechnologies.com/wp-content/themes/blt/nme.js"></script>
<link rel="stylesheet" media="screen" href="https://blog.bandlabtechnologies.com/wp-content/themes/blt/nme.css"/>
<!-- Facebook Pixel Code -->
<script>
  !function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '2300206660218433');
  fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none"
  src="https://www.facebook.com/tr?id=2300206660218433&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code --><script id="mcjs">!function(c,h,i,m,p){m=c.createElement(h),p=c.getElementsByTagName(h)[0],m.async=1,m.src=i,p.parentNode.insertBefore(m,p)}(document,"script","https://chimpstatic.com/mcjs-connected/js/users/bba8a163bb9011787872f7ea4/8a52534756ff2faee5816da7f.js");</script>

</body>

</html>
