The PS5 will not be backwards compatible with PS3 games and older

“We couldn’t reach the implementation of such compatibilities”

The PlayStation 5 will not support backwards compatibility for games from the PS3 or its predecessors, according to Sony Interactive Entertainment CEO Jim Ryan.

While it was previously confirmed that the PS5 would support up to “99 per cent” of PS4 games, the same courtesy will not be extended to previous console generations. Ryan confirmed the news during a recent interview with Japanese magazine Famitsu, as translated by Siliconera.

When asked by Famitsu if the PS5 would support games from the PS3 and older, Ryan responded: “We keep in mind the engineering specialised for the PS5, as we produced the device. In the midst of that, the PS4 already has 100 million players; we thought they ought to want to play PS4 titles on the PS5 as well indeed, so we included compatibility with the PS4.”

Advertisement

“While implementing that, we also focused our efforts on taking in the high-speed SSD and the new controller DualSense at the same time. So, unfortunately, we couldn’t reach the implementation of such compatibilities,” he added.

Ryan’s comments corroborates a previous update from Ubisoft, which stated that the PS5 would not support PS3 games and older back in August. “Backwards compatibility will be available for supported PlayStation 4 titles, but will not be possible for PlayStation 3, PlayStation 2, or PlayStation games,” it said.

In other news, Sony has confirmed that several upcoming first-party PlayStation exclusives will be released on PS4. Owners of these games on PS4 will receive free next-gen upgrades when they switch to the PS5.

The PS4 will also reportedly remain an important aspect of Sony’s hardware slate for the next three or four years, as the company recognises that not all of its users will transition to the next-gen console so quickly.

Advertisement
  • Related Topics
  • PS5
Advertisement
Advertisement